В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Даун766
Даун766
04.02.2022 18:51 •  Информатика

составить программу табулирования функции заданной рекурентной формулой. f(0)=1; f(1)=2; f(n+2)=2*f(n+1)-n

Ответ:
dmitrylazar1
dmitrylazar1
10.07.2020 18:21
Function f(n:integer): integer;
begin
  if n=0 then f := 1
  else if n=1 then f := 2
  else f := 2*f(n-1)-n+2;
end;

var n: integer;
begin 
  writeln('n':5, 'f(n)':10);
  for n := 0 to 20 do
    writeln(n:5, f(n):10);  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?