В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SirenaLi27
SirenaLi27
27.12.2021 04:30 •  Информатика

Составить программу которая формирует массив из 9 случайных целых чисел на промежутке от -30,30 и вычислите: а) сумму отрицательных чисел б) произведение чётных чисел

Ответ:
лина593
лина593
02.10.2020 01:13
Var
   mas: array [1..9] of integer;
   summ, count: integer;
   i: integer;
begin 
   randomize;
   summ := 0;
   count := 1;

   for i := 1 to 9 do
   begin
      mas[i] := random(-30, 30);
      write(mas[i] : 4);
      if mas[i] < 0 then summ := summ + mas[i];
      if mas[i] > 0 then count := count * mas[i];
   end;

   writeln('');
   writeln('Сумма отрицательных элементов: ', summ);
   writeln('Произведение положительных элементов: ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?