Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Angelona19
10.05.2022 00:49 •
Информатика
Дано целое число. написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, в противном случае.
Ответ:
nata3212
10.07.2020 15:19
Вот такая программа (для PascalABC.NET). И еще ты не сказал, что делать с числом, если оно равно 0?
var a,x:integer;
begin
read(a);
if a<0 then x:=0 else x:=a;
writeln(x);
end.
Не забудь откомпилировать перед проверкой.
0,0
(0 оценок)
Популярные вопросы: Информатика
KrIs1girl
08.05.2023 08:54
Впаскалеabc: 1)вывести на экран квадраты и кубы чисел от 2 до 10 2)найти сумму целых положительных четных чисел меньше 200 3) найти сумму целых положительных чисел, кратных 4 и меньше...
Ksyufenka
08.05.2023 08:54
Якою мовою написана операційна система windows....
KoKaina
16.08.2022 05:41
Как 45 будет представлено в десячиной системе...
sisennova03
27.02.2023 11:43
с 7-ым это вопрос жизни и смерти (контрольная) , за ранее...
Sungatullinraf
07.07.2021 08:46
1) Avast! Найдите основные особенности этого антивируса Free Antivirus. 2.Напишите пути заражения вирусом...
555Sofia555
07.07.2021 08:46
C++ В массиве хранятся сведения о количестве осадков, выпавших за каждый день января. Определить общее количество осадков за январь...
ketti336
19.02.2023 17:54
Реализуйте полученое задание на на языке С++ : Сумма квадратов первых десяти натуральных чисел равна 1 2 + 2 2 + ... + 10 2 = 385 Квадрат суммы первых десяти натуральных чисел равен...
nargiz999
07.11.2020 15:25
Що буде виведено на екран після виконання фрагменту програми: N = 3; for( i=1; i =N; i++ ) cout 1 ; )...
OverТупойШкольник
15.02.2023 08:10
Не використовуючи формулу суми геометричної прогресії, обчислити 1+x+x2+x3+ ... +xn...
аишамамедова
12.05.2023 22:32
Як виконується фрагмент наведений на малюнку...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,x:integer;
begin
read(a);
if a<0 then x:=0 else x:=a;
writeln(x);
end.
Не забудь откомпилировать перед проверкой.