В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
klepekhin
klepekhin
11.10.2022 01:34 •  Информатика

написать программу в паскале) с клавиатуры ввели число. если это число нечетное, то нужно найти сумму чисел в диапазоне от 1 до этого числа, иначе вывести сообщение о том, что число нечетное.

Ответ:
SofiCoRainbow1
SofiCoRainbow1
10.07.2020 12:36
Заметим, что числа образуют арифметическую прогрессию, а её сумма известна:
S= \frac{a_1+a_n}{2}\times n= \frac{1+n}{2}\times n
Поэтому два варианта программы: один вычисляет сумму накоплением, второй сразу определяет результат по формуле. Хороший пример того, что программист должен знать математику.

var
  n, i, s: integer;

begin
  Write('Введите натуральное число: ');
  Readln(n);
  if (n mod 2) = 0 then
  begin
    s := 0;
    for i := 1 to n do s := s + i;
    Writeln('Сумма чисел от 1 до ', n, ' равна ', s)
  end
  else Writeln('Введено нечетное число')
end.

Тестовое решение:

Введите натуральное число: 8
Сумма чисел от 1 до 8 равна 36

var
  n, s: integer;

begin
  Write('Введите натуральное число: ');
  Readln(n);
  if (n mod 2) = 0 then
    Writeln('Сумма чисел от 1 до ', n, ' равна ', ((1 + n) * n) div 2)
  else Writeln('Введено нечетное число')
end.

Тестовое решение:

Введите натуральное число: 8
Сумма чисел от 1 до 8 равна 36
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?