Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Сенсей14
19.01.2021 02:45 •
Информатика
Написать программу которая находит сумму цифр числа паскаль ( ну или хотя бы идейку подкиньте)
Ответ:
arsen20171
10.07.2020 09:30
Program summa;
var a,x:integer;
i,s:integer;
begin
writeln('введите целое число');
readln( a );
x:=a;
s:=0;
while ( x<>0 ) do begin s := s + (x mod 10);
x := x div 10;
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Lesya2601
04.09.2021 04:57
Установить, является ли предложение высказыванием, и если является, истинно оно или ложно. а) Волга впадает в Каспийское море б) 2 4 в) Пустое множество г)...
kerikmr1
02.08.2022 18:52
Текст длиной 36864 символов закодирован с алфавита, содержащего 1024 символа. сколько килобайт занимает в памяти этот текст?...
mssalina5
02.08.2022 18:52
Какой организации используется в www?...
nelli37
23.04.2023 12:03
Найти периметр равносторонего треугольника если длина его сторон величина переменной и вводиться с клавиатуры....
sofaloverrulitp0a6jz
05.02.2020 18:24
Восстанови условие по тексту программы. var f, x: real; begin writeln ( введите значение x ) ; readln (x); f: =-2*x*x+4*x-1 . 4; writeln ( значение функции f равно...
ZenRenson
05.02.2020 18:24
Введите только время ( только часы) и напечатайте соотвествующие этому времени сообщение: доброе утро , добрый вечер, доброй ночи...
daqqwe
13.06.2020 09:42
2. составить программу к следующей : «американский дедушка, подарил своему внуку на 1 день рождения 1$. каждый следующий день рождения он удваивал свой предыдущий...
zhenya4546
13.06.2020 09:42
Pascalabc как возводить в степень 5 , ctg x , y-1 ? всю программу писать не надо только саму команду...
esrogalov
22.01.2021 21:48
Заполните пропуски числами а) 5 кбайт =__байт =; б) =__байт = 12288 бит; в) =__байт = 213 бит; г) =1536 мбайт= =__кбайт; д) 512 кбайт = 2__ байт = 2__ бит....
ViktoriaDog2006
12.05.2021 16:25
Какое слово можно составить из букв т р е а о м н...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,x:integer;
i,s:integer;
begin
writeln('введите целое число');
readln( a );
x:=a;
s:=0;
while ( x<>0 ) do begin s := s + (x mod 10);
x := x div 10;
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.