В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
foxmanlp
foxmanlp
28.05.2020 20:43 •  Информатика

Составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с четными положительными значениями.

Ответ:
Keklo12
Keklo12
02.10.2020 00:48
Var a: array[1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
   begin
     readln(a[i]);
     if (a[i] mod 2 = 0) and (a[i] > 0) then writeln ('Положительное и четное: ', a[i]);
   end;
end.

//Программа проверяет каждое число при вводе, т.е. если введённое число является положительным и четным, то программа его сразу же выводит.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?