В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Криста02
Криста02
16.07.2020 10:53 •  Информатика

Напишите программу, которая в зависимости от введенного возраста добавляет слова «год», «года» или «лет». например, при вводе возраста 1, программа сообщает «1 год», при числе 2 – «2 года», при числе 125 – «125 лет».

Ответ:
KageyamaT
KageyamaT
10.07.2020 08:56
Var age:integer;
begin
  readln(age);
  if ((age mod 100 >= 10) and (age mod 100 <= 19)) then writeln(age, ' лет')
  else if (age mod 10 = 1) then writeln(age, ' год')
  else if ((age mod 10 >= 2) and (age mod 10 <= 4)) then writeln(age, ' года')
  else writeln(age, ' лет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?