В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hdhdhhxhxu
hdhdhhxhxu
18.06.2022 23:24 •  Информатика

Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10. в pascalabc

Ответ:
joker9494
joker9494
07.06.2020 01:47

uses Crt; 
var s,i:integer; 
begin 
ClrScr; 
i:=0; 
s:=0; 

While i<10 do 
Begin 
i:=i+2; 
s:=s+i; 
end; 
writeln('Summa chetnih ot 1 do 10 = ', s); 

i:=1; 
s:=1; 
While i<9 do 
Begin 
i:=i+2; 
s:=s*i; 
end; 
writeln('Proizv nechetnih ot 1 do 10 = ', s); 
readln; 
end.

0,0(0 оценок)
Ответ:
Yurgent
Yurgent
07.06.2020 01:47

Program asd;

var chet,nechet,i:integer;

begin

for i:=1 to 10 do begin

     If (i div 2)=0 then chet:=chet*i;

     If (i div 2)=1 then nechet:=nechet+i

end;

Writeln(chet,nechet);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?