В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AzNas
AzNas
11.11.2020 12:49 •  Информатика

Паскаль составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

Ответ:
женя1084
женя1084
07.06.2020 01:46

var

  a: array [1..10] of integer; //Инициализируем массив из 10 целых чисел

  i: integer;

begin

  for i:= 1 to 10 do

  begin

    a[i]:= random(19) + 1; //Заполняем массив случайными числами от 1 до 20

    if a[i] mod 2 = 1 then write(a[i], '  '); {Если очередной элемент массива нечетный, то он выводится}

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?