В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
вщылыл234
вщылыл234
23.05.2023 15:00 •  Информатика

Написать программу с исаользованием функции. дано n целых чисел. подсчитеть количество чисел, в записи которых нет цифры 8.

Ответ:
дариана2006
дариана2006
09.07.2020 22:29
Var A:Array[1..100] of Word; N,Max_S,i,I_max:Byte; Function Sum_of_figures(p:Word):Byte; var d:Word; S,j:Byte; begin d:=10000; S:=0; For j:=1 to 5 do begin S:=S+(p div d); p:=p mod d; d:=d div 10; end; Sum_of_figures:=S; end; Begin Randomize; Write('N= '); Readln(N); Writeln; Writeln('Initial array:'); For i:=1 to N do begin A[i]:=Random(65535); Write(A[i]:8); end; Writeln; Writeln; Writeln('Sums of figures:'); Max_S:=0; For i:=1 to N do begin Write(Sum_of_figures(A[i]):8); If Sum_of_figures(A[i])>Max_S then begin Max_S:=Sum_of_figures(A[i]); I_max:=i; end; end; Writeln; Writeln; Writeln('Maximal sum of figures (',Max_S,') has the element N',I_max,' equal to ',A[I_max]); Readln; End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?