В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Violent111
Violent111
12.05.2021 04:19 •  Информатика

Составить программу в paskal abc лицензионный сбор взимается в следующих размерах к минимальной месячной оплате труда в зависимости от действия лицензии: до 1 года – 30%, от 1 до 2 лет – 40%, от 2 до 3 – 50%, от 3 до 4 лет – 60%, от 4 до 5 – 70%. в случае утери лицензии сбор 20% от первоначального сбора. составьте программу определения лицензионного сбора.

Ответ:
Dipper17
Dipper17
02.10.2020 00:22
Var
  z, s: real;
  n, p: integer;

begin
  Write('Введите размер оплаты труда: ');
  Readln(z);
  Write('Лицензия первичная (1) или повторная (2)? ');
  Readln(p);
  Writeln('На сколько лет выдается лицензия?');
  Writeln('0 - до года, 1 - 1-2 года, 2 - 2-3 года,');
  Write('3 - 3-4 года, 4 - 4-5 лет: ');
  Readln(n);
  case n of
    0: s := 0.3 * z;
    1: s := 0.4 * z;
    2: s := 0.5 * z;
    3: s := 0.6 * z;
    4: s := 0.7 * z;
  else s := 1e9
  end;
  if p = 2 then s := 0.2 * s;
  Writeln('Сумма лицензионного сбора составит ', s:0:2)
end.

Тестовое решение:

Введите размер оплаты труда: 26400
Лицензия первичная (1) или повторная (2)? 1
На сколько лет выдается лицензия?
0 - до года, 1 - 1-2 года, 2 - 2-3 года,
3 - 3-4 года, 4 - 4-5 лет: 2
Сумма лицензионного сбора составит 13200.00
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?