В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lorencz2002
lorencz2002
01.02.2023 03:15 •  Информатика

1) даны два числа а и b. написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. 2) дано целое число. написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, противном случае. 3) дано целое число n. написать программу увеличивающую его на 10, если число больше 0.

Ответ:
kust2
kust2
09.07.2020 16:57
Задача 1
var
a,b:Integer;
Begin
 Read(a,b);
 if (a>b) then Writeln(b)
  else if (a<b) then Writeln(a)
  else Writeln('Числа равны');
end.

Задача 2
var
n:Integer;
Begin
 Read(n);
 if (n<0) then Writeln(0)
  else Writeln(n);
end.

3адача 3.
var
n:Integer;
Begin
 Read(n);
 if (n>0) then Writeln(n+10)
  else Writeln(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?