В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
medovd
medovd
01.01.2023 04:40 •  Информатика

Напишите программу вычисления суммы первых чисел фибоначи, таких, что их значение s не должно превышать типа integer для pascal

Ответ:
Катя0Кот
Катя0Кот
09.07.2020 15:51
Компилятора нету,попробуй этот код
var
n,sum,a,b,c,i:integer;
begin
a:=0;
b:=1;
readln(n);//Посчитать сумму первых n чисел
for i:=1 to n do
begin
sum:=sum+a;
c:=a;
a:=b;
b:=c+a;
end;
writeln(sum);
end.

//Через repeat until
var
n,sum,a,b,c,i:integer;
begin
a:=0;
b:=1;
i:=0;
readln(n);//Посчитать сумму первых n чисел
repeat
sum:=sum+a;
c:=a;
a:=b;
b:=c+a;
i:=i+1;
until i>=n;
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?