В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
asiraz03
asiraz03
24.06.2022 13:53 •  Информатика

Паскаль 1.составить программу которая проверяет четное ли это число 2.составить программу которая уравнивает два числа a и b 3.составить программу которая проверяет трехзначное ли это число

Ответ:
arslanbaiguskap0c2gw
arslanbaiguskap0c2gw
25.05.2020 10:25

1)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if(num mod 2 = 0) then  

   write('Число четное')

 else  

   write('Число нечетное');

end.

2)

var

 a, b, i: integer;

begin

 writeln('Введите a');

 read(a);

 writeln('Введите b');

 read(b);

 if (a > b) then

   swap(a, b);

 for i := 0 to  

 b - a - 1 do

   a := a + 1;

end.

3)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if (num div 1000 = 0) and (num div 100 <> 0) then  

   write('Число трехзначное')

 else  

   write('Число не трехзначное');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?