В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
taylakova090820
taylakova090820
22.04.2020 05:46 •  Информатика

№1 требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и ь хотя бы одно четное. была написана следующая программа: • var a, b: integer; • begin • readln(a, b); • a : = a mod 2; • if a > 0 then b : = b mod 2; • if b > 0 then • writeln ('четных чисел нет') • else • writeln ('четное число есть'); • end. доработайте эту программу таким образом, чтобы решалась верно. №2 с клавиатуры вводится трёхзначное число. нужно вывести ответ «да», если все его цифры четные, и ответ «нет» в остальных случаях. если введено не трёхзначное число, должно быть выведено сообщение «неверное число».

Ответ:
lotostp
lotostp
08.07.2020 20:48
N1
var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;
b := b mod 2;
•​ if (b > 0) and (a > 0) then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');
end.

N2

#include <iostream>

using namespace std;

int main()
{
  int a;
  cin >> a;
  if(a < 100 || a > 999) cout  << "Неверное число" << endl;
  else
  {
    int a1 = a/100;
    int a2 = (a/10)%10;
    int a3 = a%10;
    if(a1%2==a2%2==a3%2==0) cout << "Да" << endl;
    else cout << "Нет" << endl;
  }
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?