В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
курма4
курма4
29.04.2022 21:04 •  Информатика

Нужно написать программу на языке турбо паскаль, которая бы вычисляла значение выражения по формуле e^(x+y) - степень! заранее

Ответ:
Никольнейв
Никольнейв
01.10.2020 23:32
Var
  a, b, c, d, e, x, y, z: real;

begin
  Write('Введите через пробел a,b,c,d,e,x,y: ');
  Readln(a, b, c, d, e, x, y);
  if e > 0 then
    Writeln((a / c) * (b / d) - ((a * b - c) / (c * d)) * exp((x + y) * ln(e)))
  else if e = 0 then Writeln((a / c) * (b / d) - ((a * b - c) / (c * d)))
  else Writeln('e<0 недопустимо!')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?