В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
FuzziBoy
FuzziBoy
06.03.2023 14:00 •  Информатика

Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения площади круга: s=pi *r^2

Ответ:
nazira15
nazira15
08.07.2020 08:43
procedure MinMax(var min, max: real);
var
  a: real;
begin
  if (min > max) then
  begin
    a := min;
    min := max;
    max := a;
  end;
end;

var
  r1, r2: real;
begin
  readln(r1, r2);
  r1 := pi * sqr(r1);
  r2 := pi * sqr(r2);
  MinMax(r1, r2);
  writeln('S = ', r2 - r1);
end.
Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения пл
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?