В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Piloti3p6i
Piloti3p6i
12.03.2020 15:55 •  Информатика

Написать программу паскаль - вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры

Ответ:
Лоликус
Лоликус
08.07.2020 08:18
Var
  arr : array [1..30] of integer;
  i, number : integer;
begin
  //Заполнение массива случайными числами
  for i := 1 to 30 do
    arr[i] := Random(10000) - 5000;
  //---
  //Считывание номера элемента и проверка на соответствие условию
  write('Введите число: ');
  readln(number);
  if not (number in [1..30]) then
  begin
    write('Ошибка. Номер элемента выходит за границу массива');
    Exit;
  end;
  //---
  //Вывод массива с учётом условия
  for i := 1 to 30 do
    if arr[i] > arr[number] then
      write(arr[i], ' ');
  //---
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?