В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
trushinaveronic
trushinaveronic
26.05.2020 05:26 •  Информатика

Напишите программу, которая будет получать на вход число n и 3 символа, а затем рисует с списков квадрат nxn из этих 3 символов по правилам: по диагонали – символ 1; все, что над ним – символ 2; все, что под диагональю – символ 3. python!

Ответ:
MAXXB
MAXXB
08.07.2020 07:15

#с списков так с списков

N = int(input())

a, b, c = input(), input(), input()

arr = [['' for j in range(N)] for i in range(N)]

for i in range(N):

   for j in range(N):

       if i == j:

           arr[i][j] = a

       elif j > i:

           arr[i][j] = b

       else:

           arr[i][j] = c

       print(arr[i][j], sep='', end='')

   print()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?