В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LuizaLAIKE
LuizaLAIKE
06.04.2020 15:20 •  Информатика

Написать программу в турбо паскале. : дан текстовый файл f. исключить гласные буквы из строк и поместить результат в файл q.

Ответ:
Nikbooc
Nikbooc
01.10.2020 22:53
var
  f, q: Text;
  i: integer;
  s: string;

begin
  Assign(f, 'in.txt');
  Reset(f);
  Assign(q, 'out.txt');
  rewrite(q);
  while not EOF(f) do
  begin
    readln(f, s);
    i := 1;
    while (i <= length(s)) do
    begin
      if (upcase(s[i]) in ['А', 'Е', 'Ё', 'И', 'О', 'У', 'Ы', 'Ю', 'Я']) then
        delete(s, i, 1);
      inc(i);
    end;
    writeln(q, s);
  end;
  close(f); close(q);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?