В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Nastya8laif
Nastya8laif
17.06.2022 07:50 •  Информатика

Составить программу на языке паскаль. составить блок схему. дан массив вещественных чисел. ко всем отрицательным элементам прибавить элемент с номером , к остальным - элемент с номером .

Ответ:
ruchev06
ruchev06
08.07.2020 06:12
Const
  m=10;
var
  i,s,n,m1,m2:integer;
  a:array[1..m]of integer;
begin
write('Исходный массив: ');
for i:=1 to m do
  begin
  a[i]:=random(-5,10);
  write(a[i],' ');
  end;
writeln;
  repeat
  write('Введите m1 и m2: ');
  readln(m1,m2);
  until (m1>0) and (m2>0) and (m1<=m) and (m2<=m);
n:=a[m1];
s:=a[m2];
write('Измененный массив: ');
for i:=1 to m do
  begin
  if a[i]<0 then a[i]:=a[i]+n
    else a[i]:=a[i]+s;
  write(a[i],' ');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?