В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
maximruba
maximruba
15.08.2022 13:13 •  Информатика

Напишите программу для 2. на плоскости дан треугольник abc, задаваемый координатами своих вершин (вводятся три пары чисел). определить, является ли треугольник abc прямоугольным. дополнительно: определить координаты центра треугольника.

Ответ:
megais
megais
08.07.2020 06:06
Var
  a: array [1..6] of real;
  q, b, c: real;

begin
  for i: byte := 0 to 2 do
    readln(a[i * 2 + 1], a[i * 2 + 2]);
  q := sqrt(sqr(a[1] - a[3]) + sqr(a[2] - a[4]));
  b := sqrt(sqr(a[5] - a[3]) + sqr(a[6] - a[4]));
  c := sqrt(sqr(a[5] - a[1]) + sqr(a[6] - a[2]));
  if ((q + b > c) and (q + c > b) and (b + c > q)) then
  begin
    if (max(q, max(b, c)) = sqrt(sqr(min(q, min(b, c))) + sqr(min(q, max(b, c then 
      writeln('Прямоугольный!');
    writeln(String.Format('Геом. центр - ({0}; {1})', (a[1] + a[3] + a[5]) / 3, (a[2] + a[4] + a[6]) / 3));
  end
  else
    writeln('Нет такого ▲');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?