В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу в паскале.предложение состоит из слов, между словами один пробел, а после последнего слова точка. найти длину самого длинного слова

Ответ:
TamaraKengurs
TamaraKengurs
08.07.2020 01:43
var
  x: array of string;
  y: string;

begin
  //readln(y);
  y := 'Привет мой дорогой и прекрасный умопомрач мир';
  x := y.Remove(y.Length - 1).Split(' ');
  y := x[0];
  foreach w: string in x do
    if (y.Length <= w.Length) then
      y := w;
  writeln(y.Length);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?