В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Zaynab2897
Zaynab2897
11.11.2021 19:47 •  Информатика

Составить программу на паскаль. слова могут содержать любые символы языка. найти и вывести в самом длинномслове все символы, отличные от заглавных латинских букв. использовать множества.

Ответ:
никиумняшка
никиумняшка
07.07.2020 23:39
var  
  a       : array of string;
  str, m: string;

begin
  readln(str);
  a := str.Split(' ');
  foreach str in a do
    if (m.Length < str.Length) then
      m := str;
  foreach kchr: char in m do
    if not (kchr in ['A'..'Z']) then
      write(kchr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?