В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Cheter22871
Cheter22871
16.02.2021 07:48 •  Информатика

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше. нахождение количество цифр числа оформить в виде функции решение на паскале, написать программу

Ответ:
nata1116
nata1116
07.07.2020 23:01
function len(a: integer): byte;
begin
  result := Length(IntToStr(a));
end;

var
  a, b: integer;

begin
  for i: byte := 1 to 5 do //Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее
  begin
    readln(a);
    if (len(a) > len(b)) then
      b := a;
  end;
  writeln(b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?