В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rusrusik
rusrusik
11.02.2022 05:53 •  Информатика

Написать программу.дана матрица а, имеющая n строк и n столбцов. сформируйте два одномерных массива. в один перешлите четные, а в другой — нечетные элементы матрицы. выведите на экран все массивы. . нужна

Ответ:
alekshaino
alekshaino
07.07.2020 22:49
Const n=5;
var a:array[1..n,1..n] of integer;
b,c:array[1..n*n] of integer;
k1,k2,i,j:integer;
begin
k1:=0;
k2:=0;
for i:=1 to n do
  for j:=1 to n do begin
    read(a[i,j]);
    if odd(a[i,j]) then begin inc(k2); c[k2]:=a[i,j]; end
    else begin inc(k1); b[k1]:=a[i,j]; end;
  end;
writeln('Четные');
for i:=1 to k1 do
write(b[i],' ');
writeln();
writeln('Нечетные');
for i:=1 to k2 do 
write(c[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?