В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
йцукенг27
йцукенг27
28.02.2022 01:07 •  Информатика

Написать программу на языке паскаль, которая вычисляет значение заданной в таблице функции y . вывести в окне программы результаты для трех вариантов переменной x.

Ответ:
ramon8
ramon8
07.07.2020 15:20
Program b1;
var y,x1,x2,x3:Real;
Begin

Writeln('Write x1,x2,x3 : ');
Readln(x1,x2,x3);
if x1>4 then writeln(sqrt(abs(sin(sqr(x1)-1)/cos(sqr(x1)-1))):10:20);
if x1>=0 then if x1<=4 then writeln(-2*x1:10:20);
if x1<0 then writeln(Exp(cos(x1)):10:20);

if x2>4 then writeln(sqrt(abs(sin(sqr(x2)-1)/cos(sqr(x2)-1))):10:20);
if x2>=0 then if x2<=4 then writeln(-2*x2:10:20);
if x2<0 then writeln(Exp(cos(x2)):10:20);

if x3>4 then writeln(sqrt(abs(sin(sqr(x3)-1)/cos(sqr(x3)-1))):10:20);
if x3>=0 then if x1<=4 then writeln(-2*x3:10:20);
if x3<0 then writeln(Exp(cos(x3)):10:20);

Readln(x1);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?