В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Надо написать программу в паскале. : введите три трёхзначных числа. найти разность между наибольшим м наименьшим. заранее !

Ответ:
damirpro
damirpro
07.07.2020 14:37
Begin
  var a, b, c: single;
  readln(a, b, c);
  writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.

Позязя, расширеннее...
begin
  var a, b, c, d, e: single;
  readln(a, b, c);
  if (a < b) then
    d := a
  else
    d := b;
  if (c < d) then
    d := c;
  if (a > b) then
    e := a
  else
    e := b;
  if (c > e) then
    e := c;
    writeln(e - d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?