В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Angelina23411
Angelina23411
02.04.2023 07:39 •  Информатика

С1. составить алгоритм и написать программу на вычисление скорости или пути , при условии , если t< 3 часов , тогда вычисляем скорость иначе путь . каждую строку программы прокомментировать . входные данные t = 80 мин.

Ответ:
easyotvet01
easyotvet01
01.10.2020 21:59
Алгоритм:
Начало
Ввод t
Если t>1 часа, то 
начать выполнение операторов
ввод S;
V=S/t;
вывод V
закончить выполнение операторов
иначе 
начать выполнение операторов
ввод V;
S=Vt;
вывод S;
закончить выполнение операторов

Var S,V,t:integer;
begin
read(t);
if t>1 then
begin
read(s);
v:=s/t;
writeln('Скорость=',v);
end
else
begin
read(v);
s:=v*t;
writeln('Расстояние=',s);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?