В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
bogds2001
bogds2001
23.04.2021 11:10 •  Информатика

Написать программу для паскаль найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.

Ответ:
Сметана011
Сметана011
07.07.2020 13:53
var
  m, k, d1: single;
  i, t, d: byte;

begin
  readln(t);
  writeln();
  for i := 1 to t do
  begin
    readln(k);
    if (k > 0) then
    begin
      d1 += k;
      d  += 1;
    end;
  end;
  writeln(d1 / d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?