В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1mizik1
1mizik1
27.11.2022 15:42 •  Информатика

Составьте программу нахождения среднего арифметического всех элементов матрицы в размере 8*8

Ответ:
катя5088
катя5088
07.07.2020 01:16
Выше решение не для матрицы 8х8, а для одномерного массива из 5-ти элементов. Вот для двухмерной матрицы 8х8:

const n=8;
var a:array[1..n,1..n] of integer;
i,j,s:integer; sr:real;
begin
for i:=1 to n do
for j:=1 to n do a[i,j]:=random(50)-20;
for i:=1 to n do begin
for j:=1 to n do write(a[i,j]:4);
writeln;
end;
writeln;
sr:=0; s:=0;
for i:=1 to n do
for j:=1 to n do
s:=s+a[i,j];
sr:=s/sqr(n);
write('среднее арифметическое всех элементов матрицы = ',sr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?