В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ruslan424
ruslan424
05.08.2021 18:43 •  Информатика

Написать программу на pascal abc. дано предложение. вывести строку в обратном порядке. вывести столбиком все его буквы "и", стоящие на четных местах.

Ответ:
никита3274
никита3274
06.07.2020 21:16
Var
  str : string;
  i, count : integer;
begin
  {часть 1 - обратный порядок}
  write('Введите строку: ');
  readln(str);
  write('Результат: ');
  for i := length(str) downto 1 do
    write(str[i]);
  {часть 2 - считаем "и"}
  count := 0;
  for i := 1 to length(str) do
    if (str[i] = 'и') and (i mod 2 = 0) then
      count := count + 1;
  writeln;           {переходим на следующую строку}
  for i := 1 to count do
    writeln('и');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?