Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
krechetnickova
17.02.2020 17:43 •
Информатика
Индивидуальное зачетное напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой стрелки в градусах и радианах (помните, что тригонометрические функции в паскале работают с радианами)
Ответ:
snikola97
01.10.2020 20:17
Var
n,m:integer;
r1,r2:real;
begin
writeln('Введите количество часов: ');
readln(n);
writeln('Введите количество минут: ');
readln(m);
n:=n mod 12;
r2:=m/60*360;
r1:=(n*360+r2)/12;
writeln('Угол поворота часовой стрелки ',r1,' градусов или ',r1/180*Pi,' радиан');
writeln('Угол поворота минутной стрелки ',r2,' градусов или ',r2/180*Pi,' радиан');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Ekaeterina44
09.08.2020 01:53
ответ устно на вопросы какие носители информации ты используешь в школе ? для чего ты используешь носители информации ? каким ты можешь передать информацию соседу...
Лера99100
13.04.2023 01:36
Дана программа: Program Primer;VarM,result : real;Begin Writeln( Введите значения переменной M ); Write( M= ); Readln(M); Result := sqr((7+M)*11); Writeln (result:8:0); ...
fpu51810
08.07.2020 16:48
Сделать таблицу в open office ,,мои любимые книги,,...
Nikitos31055
08.07.2020 16:48
Почему операционная система относится к группе системных...
Assassin5510
15.02.2020 00:39
Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. программа получает на вход натуральные числа,...
Nikikiki303
14.04.2020 01:48
Сяклассом! выберите рисунок на котором представлена (-а, - о) рибосома. и отметьте функцию этого органоида. ...
RosalinaT14
03.06.2022 00:06
Вписаний у коло кут дорівнює 70градусів чому дорівнює відповідний йому центральний кут? ...
artemkovalev1
30.01.2021 14:12
15 за это! мне урок через 5 минут...
snow15
29.05.2023 17:38
Ca+h2o- ca+02- zn+o2- zn+hcl- zn+h2o- cu+znso4-...
Bernardeschi
26.08.2020 12:09
Напишите информацию о компьютерах...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n,m:integer;
r1,r2:real;
begin
writeln('Введите количество часов: ');
readln(n);
writeln('Введите количество минут: ');
readln(m);
n:=n mod 12;
r2:=m/60*360;
r1:=(n*360+r2)/12;
writeln('Угол поворота часовой стрелки ',r1,' градусов или ',r1/180*Pi,' радиан');
writeln('Угол поворота минутной стрелки ',r2,' градусов или ',r2/180*Pi,' радиан');
end.