В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Впаскале abc написать программу. дано натуральное число n. с клавиатуры вводятся n дат рождения в формате dd.mm. (например, 17.04.2014). напечатать название месяца, в котором больше всего дней рождений. если таких месяцев несколько, то напечатать название самого позднего из них.

Ответ:
Palinka1
Palinka1
06.07.2020 11:52
Var
  i,n,k,max:integer;
  s:string;
  a:array[1..12]of integer;
  naz:array[1..12]of string;
begin
naz[1]:=('январь');
naz[2]:=('февраль');
naz[3]:=('март');
naz[4]:=('апрель');
naz[5]:=('май');
naz[6]:=('июнь');
naz[7]:=('июль');
naz[8]:=('август');
naz[9]:=('сентябрь');
naz[10]:=('октябрь');
naz[11]:=('ноябрь');
naz[12]:=('декабрь');
write('Введите число N: ');
readln(n);
for i:=1 to n do
  begin
  write('Введите дату: ');
  readln(s);
  s:=copy(s,4,2);
  k:=StrToInt(s);
  a[k]:=a[k]+1;
  end;
for i:=1 to 12 do
  begin
  if a[i]>=max then
    begin
    max:=a[i];
    n:=i;
    end;
  end;
writeln('Месяц с наибольшим количеством: ',naz[n]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?