В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
darishka67854321
darishka67854321
10.01.2023 12:52 •  Информатика

Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. количество чисел должно задаваться во время работы программы. (цикл для)(паскаль )

Ответ:
Paszhaa
Paszhaa
06.07.2020 07:44
Program Nooobodyyy;
uses crt;
var
  i,how:integer;
  ch,appr,sum:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N дробных чисел и находит их среднее арифметическое');
  sum:=0;
  write('Введите количество чисел: '); readln(how);
  for i:=1 to how do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
    end;
  appr:=sum/how;
  writeln('Cреднее арифметическое равно ',appr:8:2);
end.
0,0(0 оценок)
Ответ:
ajdanayun
ajdanayun
06.07.2020 07:44
Var
  i, count : integer;
  summ, temp : real;
begin
  summ := 0;
  readln(count);
  for i := 1 to count do
  begin
    readln(temp);
    summ := summ + temp;
  end; 
  writeln(summ / count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?