В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Shiro228
Shiro228
01.06.2022 23:52 •  Информатика

Написать программу pascal и excel, которая находит длину самого длинного слова в строке.

Ответ:
nastik033
nastik033
01.10.2020 20:00
Pascal:

var s,s1,s2,max:string;
i,k,maxdl,j:integer;
begin
readln(s);
s1:=concat(s,' ');
s2:=s;
maxdl:=0;
while pos(' ',s1)>0 do begin
max:=copy(s1,1,pos(' ',s1)-1);
delete(s1,1,pos(' ',s1));
 if maxdl<pos(' ',s1)-1 then maxdl:=length(max);
end;
if length(max)>maxdl then maxdl:=length(max);
writeln(maxdl);
end.

P.s. немножко криво написано)) но работает.
0,0(0 оценок)
Ответ:
karina1zaporojckaya
karina1zaporojckaya
01.10.2020 20:00
Вариант с VBA Excel
Чтобы увидеть программу жмите Alt+F11
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?