В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kirikdementev
kirikdementev
13.04.2021 21:55 •  Информатика

Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия: а) четные числа делит на 2 и результат выводит на экран б) нечетные числа выводит на экран без изменений

Ответ:
RETYUOP
RETYUOP
06.07.2020 01:23
Var a,b,c:integer;
begin
read(a,b,c);
if odd(a) then write(a,' ')
else write(a/2,' ');
if odd(b) then write(b,' ')
else write(b/2,' ');
if odd(c) then write(c,' ')
else write(c/2,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?