В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
irushkanet
irushkanet
04.02.2022 08:44 •  Информатика

Написать программу в паскаль: 1)составьте программу, которая по заданному году и номеру месяца определит кол-во дней в этом месяце. 2)для любого 2-ух значного числа, вывести его значение в словесной форме.

Ответ:
Гасан9707
Гасан9707
05.07.2020 20:07
1)
var y,m,d:integer;
begin
read(y,m);
case m of
1,3,5,7,8,10,12: d:=31;
4,6,9,11: d:=30;
2:if(y mod 4<>0) then d:=28 else
if(y mod 100<>0) then d:=29 else
if(y mod 400<>0) then d:=28 else
d:=29;
end;
writeln(d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?