В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
victorianna03
victorianna03
04.05.2022 08:37 •  Информатика

Составьте программу, заполняющую массив заданной размерности случайными целыми числами и обрабатывающую его в соответствии с вариантом . обратите внимание на правильное использование типов данных (помните, что результат операции может отличаться от типа исходных данных). исходный массив: s[0..75] что требуется сделать: изменить знак всех четных элементов массива с четными индексами

Ответ:
clon4
clon4
01.10.2020 19:27

Program YouName;

Var i,n:Integer;

s: array[0..75] of Integer; // Объявление массива

Begin

write('Введите количество элементов массива: ');

readln(n); // Ввод кол-ва элементов массива

writeln('');

writeln('Исходный массив:');

for i:=1 to n do // Перебор от первого до n элементов массива

 Begin

  // Если используете паскаль ABC, то можно написать так: s[i]:=random(-100,100);

  s[i]:=random(100-(-100)+1)+(-100); // Заполнение элементов массива от -100 до 100.

  write(s[i], '(', i, ')',' '); // Вывод элемента массива с его порядковым номером

 End;

writeln;

writeln('');

writeln('Видоизмененный массив:');

for i:=1 to n do // Перебор от первого до n элементов массива

 Begin

  If (i mod 2 = 0) and (s[i] mod 2 = 0) then // Если элемент и значение массива четное, то..

   Begin

    s[i]:=s[i]*(-1); // Смена знака на противоположный

    write(s[i], '(', i, ')',' '); // Вывод элемента массива с его порядковым номером

   End;

 End;

writeln;

writeln('');

End.

Объяснение: Если есть вопросы, то пишите мне в лс.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?