В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yakovenko040320
yakovenko040320
04.09.2021 09:25 •  Информатика

Написать программу,которая вычисляет дату следующего дня.( pascal) ниже рекомендуемый вид работы программы.(данные введенные пользователем,выделены жирным шрифтом) введите цифрами сегодняшнюю дату(число,месяц,год) 31 12 1998 последний день месяца! с наступающим новым годом! завтра 1.1.2000

Ответ:
vaniev2006
vaniev2006
05.07.2020 16:47
Паскаль АВС.
Программа вывводит дату следующего дня. Чтоб не утяжелять программу, не стал писать проверку правильности введения даты - то есть пользователь должен вводить только правильные цифры :)

Program Upmixer;
var
  day, month, year:integer;
begin
writeln('Введите дату:');
write('День:'); read (day);
write('Месяц:'); read (month);
write('Год:'); read (year);
day:=day+1;
{если было введено 29 февраля високосного года}
if (((year mod 4)=0) and ((year mod 100)<>0) and (month=2) and (day=30)) then
  begin
    day:=1;
    month:=month+1;
  end;
{если было введено 28 февраля невисокосного года}
if (((year mod 4)<>0) and (month=2) and (day=29)) then
  begin
    day:=1;
    month:=month+1;
  end;
{другие дни}
if ((day=31) and ((month=4) or(month=6) or (month=9) or (month=11))) then
  begin
    day:=1;
    month:=month+1;
  end;
if ((day=32) and ((month=1) or(month=3) or (month=5) or (month=7) or (month=8) or (month=10))) then
begin
    day:=1;
    month:=month+1;
end;
{31 декабря}
if ((day=32) and (month=12)) then
begin
    day:=1;
    month:=1;
    year:=year+1;
end;
writeln('Завтра ', day,' ',month,' ',year);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?