В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
RaiderUp
RaiderUp
26.05.2023 08:03 •  Информатика

Написать программу в паскале: дано натуральное число n. заменить порядок следования цифр числа n на обратный.

Ответ:
Neznaika123shsgwheh
Neznaika123shsgwheh
05.07.2020 14:15
Var
  n,x:string;
  i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=length(n) downto 1 do x:=x+n[i];
writeln('Обратное число: ',x)
end.

или можно так:

var
  n:string;
begin
write('Введите число n: ');
readln(n);
writeln('Обратное число: ',ReverseString(n) )
end.
0,0(0 оценок)
Ответ:
zverrodion199911
zverrodion199911
05.07.2020 14:15
Var a, N: integer;
begin 
    writeln('Введите число'); 
    readln(N); a:=0; 
    while N>0 do begin 
        a:=a*10+N mod 10;  
        N:=N div 10; 
      end; 
   writeln (a); 
   readln; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?