В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Diana20006100500
Diana20006100500
31.05.2020 14:42 •  Информатика

Написать программу в паскале: даны целое n> 0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. найти величину наибольшего среди отрицательных чисел этой последовательности.

Ответ:
катя7354
катя7354
05.07.2020 14:15
Var
  x,max:real;
  n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
  begin
  write('Введите число ',i,': ');
  readln(x);
  if x<0 then
     begin
     if max=0 then max:=x;                     // если это первое отр.число
     if x>max then max:=x
     end
  end;
writeln('Наибольшее среди отрицательных: ',max)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?