В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kiberyblydok23
Kiberyblydok23
29.07.2021 19:12 •  Информатика

Составьте программу для решения : 1.найдите произведение квадратных корней n первых натуральных чисел 2.определить делится ли сумма цифр заданного натурального числа на 7 3.заменяет в записи натурального числа n цифру 8 на цифру 3

Ответ:
Tsenenks
Tsenenks
01.10.2020 18:55
1.
var
n, i: integer;
rez: real;
begin
rez:=1;
readln(n);
for i:=1 to n do rez:=rez*sqrt(i);
write(rez);
end.

2.
var
n: string;
i, summa: integer;
begin
readln(n);
for i:=1 to length(n) do summa:=summa+strtoint(n[i]);
if (summa mod 7)=0 then write('Делится') else write('Не делится');
end.

3.
var
n: string;
i, summa: integer;
begin
readln(n);
for i:=1 to length(n) do if n[i]='8' then n[i]:='3';
write(n);
end.

Если возникли вопросы или ошибки в ходе работы программы, пиши в ЛС или комментарии.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?