В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nikaaleksievich
nikaaleksievich
15.12.2020 17:53 •  Информатика

Напишите программу(паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр : с

Ответ:
cempalov
cempalov
05.07.2020 06:47
Var
n, k, a, i: integer;

begin
write('Введите кол-во чисел: ');
readln(n);
for i:=1 to n do
 begin
 read(a);
 if ((a mod 2) = 1) then inc(k);
end;
write(k);
end.

С использованием оператора repeat:

var
n, k, a, i: integer;
begin
write('Введите кол-во чисел: ');
readln(n);
repeat
 read(a);
 if ((a mod 2) = 1) then inc(k);
 inc(i);
 until i=n;
write(k);
end.

 n - кол-во чисел, k - кол-во нечётных чисел, a - число
Все числа вводятся через пробел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?