В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jsdfsg
jsdfsg
05.07.2021 21:52 •  Информатика

Дано натуральное число m. составить программу, которая разбивает это число на три приблизительно равных натуральных числа.​

Ответ:
polinavorkuta
polinavorkuta
01.10.2020 18:42

program raf105;

var

 n,n1,n2,n3: integer;

begin

 write('Введите число: ');

 readln(n);

 n1:= n div 3;

 n2:= n1;

 if n mod 3 = 1 then

   n3:= n1 + n mod 3

 else if n mod 3 = 2 then

 begin

   n3:= n1 + 1;

   n2:= n1 + 1;

 end

 else

   n3:= n1;

 writeln(n1,' ',n2,' ',n3);

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?