В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dianaohanesian
dianaohanesian
08.02.2023 05:48 •  Информатика

Написать программу,которая находит все четырехзначные числа abcd,для которых выполняются условия 1)a,b,c,d-разные цифры 2)a*b-c*d=a+b+c+d

Ответ:
Марина36843
Марина36843
03.07.2020 22:34
Program fofgogjoj;
var 
a,b,c,d:integer;
begin
for c:=0 to 7 do 
begin
a:=c+2; 
d:=9-c;
for b:=0 to 9 do 
begin
if (b<>c)and(b<>a)and(b<>d) then
Writeln(a,b,c,d);
Writeln;
end;
end;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?