Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Мухосранск462
21.03.2020 21:24 •
Информатика
Составить блок схему и написать программу, которая находит сумму нечетных и количество четных делителей натурального числа.(31954)
Ответ:
bagauridiana
01.10.2020 18:30
Var n,i,k,s:integer;
begin
read (n);
k:=0;
s:=0;
for i:=1 to n do
begin
if (n mod i = 0) then
begin
if (i mod 2 = 0)then
begin
k:=k+1;
end else
begin
s:=s+i;
end;
end;
end;
writeln ('Кол-во чётных - ',k);
writeln ('Сумма нечётных - ',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
alina1934
21.12.2020 01:52
Придумайте свою задачу, для решения которой необходимо воспользоваться инструментом Поиск редакции на дату (подсказка – правовая норма должна измениться)....
klarkwin
28.04.2023 10:49
Сколько команд имеет тело цикла...
braaauberg
24.01.2020 22:11
1предназначен процессор? a для вычислений ,обработки информации и работой компьютера b для вычислений и обработки информации c для работой компьютера d для обработки информации...
настякотик13
28.08.2022 14:23
Дан фрагмент таблицы истинности выражения F пеже...
ilyasterxov16
25.03.2022 13:30
Логическая функция F задаётся выражением а∨(¬b∧c) Определите, какому столбцу таблицы истинности функция F соответствует каждая из переменных a, b, c в том порядке, в котором...
RTF1111
30.07.2020 16:52
Даны двоичные числа A и B (данные в таблице). Выполните операции: а) отрицание б) соединение в) дизъюнкция г) импликация е) эквивалентность г) антиэквивалентность Вариант...
rayhan8888
10.08.2022 17:46
4. Имеются значения суточного количества осадков в сантиметрах за 31 день июля. Напишите программу, определяющую суточное количество осадков самого дождливого дня. В поле...
victorastrakhan1
02.04.2021 02:37
Питання №4 ? Як відбувається виконання команди неповного розгалуження, якщо значення логічного виразу true? а) виконується послідовність команд 1 і після цього виконується...
ExeLisor
29.10.2022 19:58
Глава 3. Программирование § 17. Введение 1. Переведите слова Python и print с английского языка на русский. Python ¬ print ¬ 2. Вася решил дополнить программу так, чтобы она...
ArtemRussia
14.01.2022 22:31
Дана программа для вычисления пути в зависимостим от введенной скорости и времени. исправь ошибки. v=float(( введите скорость , v)) t=int(input(введите время ,t)) s=v*t print()...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
read (n);
k:=0;
s:=0;
for i:=1 to n do
begin
if (n mod i = 0) then
begin
if (i mod 2 = 0)then
begin
k:=k+1;
end else
begin
s:=s+i;
end;
end;
end;
writeln ('Кол-во чётных - ',k);
writeln ('Сумма нечётных - ',s);
end.