В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hhjjkh
hhjjkh
18.03.2022 12:05 •  Информатика

Напишите программу (с циклом for) для вычисления суммы 1+1/x+1/x^2+1/x^3 + 1/x^4 + + 1/x^k для любого x.

Ответ:
liliasirbu
liliasirbu
01.10.2020 18:31
Program BiFi;
Var x,a,s:real;
k,i:integer;
Begin
readln(x);
readln(k);
s:=0;
a:=x;
for i:=1 to k do begin a:=a/x;
                      s:=s+a;
writeln(s:6:3);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?