В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
BlackSenpai
BlackSenpai
21.12.2021 23:07 •  Информатика

Напишите программу которая вводит с клавиатуры натуральное число n и выводит на экран n первых элементов последовательности: 1, 3, 7, 15, 31, 63, (4 )

Ответ:
111mart111
111mart111
03.07.2020 20:50

Каждое число в последовательности увеличивается на 2 в степени i - 1

где i это порядковый номер числа в последовательности

program raf105;

var

 x,n,i: integer;

begin

 readln(n);

 for i:=1 to n do

 begin

   x:= x + round(power(2,i-1));

   write(x,' ');

 end;

end.

PascalABC
0,0(0 оценок)
Ответ:
dashkurko1das
dashkurko1das
03.07.2020 20:50

var

k,i,a:Integer;

begin

a:=1;

readln(k);

for i:=1 to k do begin

write(a,' ');

a:=a+a+1;

end;

end.

Это паскаль

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?