В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

1. дан массив а из 10 элементов, которые заполняются случайным образом, числам от 0 100. выведите массив на экран и найдите максимальный элемент массива. 2. создать массив a из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Ответ:
Песатель
Песатель
03.07.2020 15:18
1.const  N=10;
type Vector = array [1..N] of integer;
var B: vector;   
     max :integer;
procedure IntVector(N: integer; var a: vector);
begin 
 for var i := 1 to N do  a[i] := random(100);
end;
procedure OutVector(N: integer; a: vector);
begin  for var i := 1 to N do  
begin      write(a[i]:5);
end;
end;
procedure Srav (a:vector; N,g:integer);
begin
g := a[1];
for var i:=1 to N do
if (g < a[i]) then g:=a[i];
writeln (g);
end;
Begin 
IntVector(N, B); 
writeln; 
OutVector(N, B ); 
writeln;  
Srav(B,N, max); 
writeln;
End.
2. const  N = 10;
type  Vector = array [1..N] of integer;
var  B: vector; 
     r,v : real; 
procedure IntVector(N: integer; var a: vector);
begin 
for var i := 1 to N do    
a[i] := random(20);
end;
procedure OutVector(N: integer; a: vector);
begin 
 for var i := 1 to N do  
begin   
write(a[i]:5); 
 end;
end;
function srednee(a: vector; N: integer): real;
begin 
for var i := 1 to N do   begin   result := (result + a[i]);  
end; 
end;
function kolvo(a: vector; g: real): real;
begin 
for var i := 1 to N do
   if (a[i] < (srednee(a, N)/10)) then result := result + 1;
end;
begin 
IntVector(N, B);  writeln; 
OutVector(N, B ); 
writeln; 
writeln ((srednee(B, N)/10):5:3);   r := kolvo(B, v); 
writeln(r);
end.
0,0(0 оценок)
Ответ:
MilkiWika
MilkiWika
03.07.2020 15:18
1)
constn=10;
var
i:byte;
max:real;
a:array[1..n] of real;
begin
for i:=1 to n do
a[i]:=random(100);
for i:=1 to n do
write(a[i]:3);
for i:=1 to n do
 max:=a[i];
if max<a[i] then max:=a[i];
writeln('Максимальный элемент = ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?